Controllers recognized but not working

Joystick Mapper discussion.

Controllers recognized but not working

Postby ebbletarts » Sun Dec 03, 2017 10:23 pm

Hi all,

  • The controller you are using: DS4 and Xbox 360 (primarily interested in the DS4)
  • Your OS X Version and Mac model: MacOS "Sierra" 10.12.6, Late-2011 Macbook Pro
  • The Game/App with you want to use your mapped controller with: Valdis Story: Abyssal City
  • Joystick Mapper version: Version 1.1.3 (5)

I installed Joystick Mapper just now to try and figure out some button mappings to play Valdis Story: Abyssal City since it does not support controllers (even though there's an "Enable D-Input" option in the in-game menu, grrr...), but I cannot get it to recognize any button presses from either of the following two controllers:

* Wired Xbox 360
* Wireless Dualshock 4

Both controllers work in games that support controllers, so the controllers are working.

Here are the steps I am following:

  1. Ensure either controller is connected/paired to my laptop.
  2. Open Joystick Mapper.
  3. Select a preset (I only have one right now and it has 1, non-effective binding)
  4. Select "Joystick # 0"
  5. Select the default bind that got created when I clicked "Add a new bind" on a previous iteration of testing this.
  6. Click "scan".

Once I click scan, it says "Hold any button or press any axis in your Joystick" with a 5-second countdown. Then, I press a button and nothing happens. I move a joystick and nothing happens, the countdown continues without recognizing any input. The bind remains at "Button 0 -> keyboard key A".

I saw this in the FAQ:

When my PS3 controller is connected to USB, it show as "connected" in Joystick Mapper, but no buttons or analog sticks responds! Please help me!
This one is simple, just press the central "PS" button once. The gamepad will work normally. Don't know why you need to do that, though.

So I tried pressing the PS button once when joystick mapper was focused, but it didn't help (I am using the DS4, but I thought i would give it a shot).

I have the Xbox360 driver installed:

    Xbox 360 Controller Driver
    Version 0.16.5

I am running MacOS Sierra 10.12.6, using a late 2011 Macbook Pro.

When I select "Which Joysticks Are Connected?" I see:

    There are 2 Joysticks Connected.

    #1 : Xbox 360 Wired Controller
    #2 : Wireless Controller

"Wireless Controller" is how the DS4 shows up in the Bluetooth preferences.

I also tried rebooting, still no dice. My next step was going to be upgrading to High Sierra, but I thought I'd post here first.
Posts: 1
Joined: Sun Dec 03, 2017 9:51 pm

Re: Controllers recognized but not working

Postby keepsakephoto » Tue Dec 26, 2017 5:09 am

Same issue here, the scan function not working with a PS4 controller
Posts: 1
Joined: Tue Dec 26, 2017 5:06 am

Return to Joystick Mapper

Who is online

Users browsing this forum: No registered users and 1 guest